Scheduled maintenance for this weekend is complete and all services are operating as normal. No major disruptions were reported during the window.
This work keeps the CareHires platform on the latest secure, supported technology — strengthening the foundation that all our services run on. No action is required from customers; the improvements take effect automatically.
The next planned maintenance window forms part of the same wider platform upgrade and will take place next weekend. Details will be published on this page in advance.
Thank you for your patience during the maintenance window.
Posted May 03, 2026 - 06:34 UTC
Verifying
Maintenance work is complete.
Post-maintenance verification is now underway across all affected services. The platform is operating as normal and no action is required from customers.
Posted May 03, 2026 - 06:25 UTC
In progress
Scheduled maintenance is now underway.
The platform is operating as normal; you may notice brief, intermittent disruption during this window. Updates will follow as the work progresses.
Posted May 01, 2026 - 23:49 UTC
Scheduled
We are carrying out scheduled maintenance on the infrastructure that powers CareHires as part of a planned platform upgrade. This work keeps CareHires running on the latest supported, secure, and compliant technology.
What to expect: ------------------- - No planned downtime is anticipated. - You may experience brief, intermittent disruption during this window — for example, a slow page load or a request that needs to be retried. - Outside this window, the platform will operate as normal.
Affected services: CareHires web platform, mobile experience, and integrations.
No action is needed on your end. If you do notice anything during the window, a quick retry will usually resolve it. Our support team is available as always if you need us.
This forms part of a wider platform upgrade taking place over the coming weeks. Any further maintenance windows will be scheduled during off-peak hours and published on this page in advance.
Posted May 01, 2026 - 17:14 UTC
This scheduled maintenance affected: Care Hires - Core API - System Backend Services, Care Worker - Mobile Apps (Worker Mobile Application (IOS), Worker Mobile Application (Android)), and Care Hires - Web Apps (Supply Chain Management (Web), Supply Chain Management (Mobile optimised web), Marketplace (Web), Care Rota (Web), Agency Academy Sub portal (Web)).