Important Notice Regarding System Access/Loading Issues
Incident Report for Care Hires
Resolved
This incident has been resolved.
Posted May 15, 2024 - 19:33 UTC
Identified
We are aware of the intermittent issues that are causing login and data loading problems. Our team is working diligently to find a solution soon.

If you are experiencing difficulties logging in or accessing certain parts of our system, please follow these simple steps to temporarily resolve the issue

1) Refresh the page after waiting for one minute.
2) If the issue persists, close the tab, clear your browser cache, and try accessing the system again.
3) Should the problem continue after several attempts, please contact our 24/7 support team for further assistance.

We are committed to providing a smooth experience and are working diligently to resolve these intermittent issues permanently. Thank you for your patience and understanding.
Posted May 01, 2024 - 08:09 UTC
This incident affected: API and Care Hires - Web (Care Hires - Neutral Vendor (Web)).