Issue with invoices generated in May Week 4 invoice cycle
Incident Report for Care Hires
Resolved
We have resolved this issue and all invoices related to May week 4 is now generated correctly
Posted May 25, 2022 - 10:51 UTC
Investigating
We have identified an issue in invoice auto approval process and in few invoices generated in May week 4 invoice cycle. Team is further investigating the root cause.

We will be doing the need full to rectify this and provide a permeant solution in the future invoice cycle.
Posted May 25, 2022 - 07:17 UTC
This incident affected: API and Care Hires - Web (Care Hires - Neutral Vendor).